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About the ABBYY FlexiCapture Connector for Blue

Prism

ABBYY FlexiCapture enables users to perform high-quality full-text recognition, classify documents,

detect fields and capture their data, and convert files into various formats (e.g. searchable PDF).

ABBYY FlexiCapture Integration Solution for Blue Prism is intended for  loading document files and

captured data into the Blue Prism robotic process automation.

Architecture

The ABBYY FlexiCapture 12 integration solution for Blue Prism comprises the following three

components:

· FlexiCapture 12 VBO, a business object that operates on the Blue Prism side. This object sends

data to ABBYY FlexiCapture 12 and receives results in synchronous mode.

· FlexiCapture 12 Listener, a web service that operates on the Blue Prism side. This service handles

requests from ABBYY FlexiCapture 12.

· A Blue Prism connector operating on the ABBYY FlexiCapture 12 side. This connector sends

requests to the FlexiCapture 12 Listener web service at the export stage.

System requirements

Software requirements for FlexiCapture 12 VBO and FlexiCapture 12 Listener:

· Blue Prism 6.2.1 or higher

· Microsoft .NET Framework 4.5

Software requirements for the ABBYY FlexiCapture Connector for Blue Prism:

· ABBYY FlexiCapture 12 Distributed (12.0.2)

· ABBYY FlexiCapture Cloud

· Microsoft .NET Framework 4.5

Usage scenarios

The ABBYY FlexiCapture Integration Solution for Blue Prism can typically be used in the following three

scenarios.

1. FlexiCapture as an unattended service: files are sent synchronously from Blue Prism to

ABBYY FlexiCapture 12; no verification is required

The FlexiCapture 12 VBO component, which runs on the Blue Prism side, sends a file to ABBYY

FlexiCapture 12 and gets back extracted fields and exported files. In this scenario, files received by

ABBYY FlexiCapture 12 do not require verification, so once the recognition is completed, they go directly

to the export stage.

Note: The ABBYY FlexiCapture operator must have the role of Scanning Operator or Administrator
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for the given project and batch type. These roles are granted by the administrator in the Administration
and Monitoring Console.

2. FlexiCapture as input: files and data are sent synchronously from ABBYY FlexiCapture 12 to

Blue Prism

The ABBYY FlexiCapture Connector for Blue Prism is used at the export stage in ABBYY FlexiCapture

12 according to a script export profile. The connector sends files and extracted fields to the FlexiCapture

12 Listener web service. ABBYY FlexiCapture 12 may receive image files from the Scanning Station or

FlexiCapture Mobile Client, for example.

3. FlexiCapture as an attended service: files are sent asynchronously from Blue Prism to

ABBYY FlexiCapture 12; verification is required 

The FlexiCapture 12 VBO, which runs on the Blue Prism side, sends a file to ABBYY FlexiCapture 12

and gets back a URL to a document verification page on the Web Verification Station. The user clicks

the link and verifies the document. Once the verification is completed, a script export profile is applied on

the ABBYY FlexiCapture 12 side, which makes the ABBYY FlexiCapture Connector for Blue Prism send

the files and extracted field data to the FlexiCapture 12 Listener web service.

Note: The ABBYY FlexiCapture operator must either have the roles of Scanning Operator (to send
documents) and Verification Operator (to receive URL to document verification page on the Web
Verification Station) for the given project and batch type, or the role of Administrator.
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ABBYY FlexiCapture as an unattended service

To configure this scenario, complete the following steps:

1. On the Blue Prism side, install and configure the FlexiCapture 12 VBO.

2. To enable the FlexiCapture 12 VBO to receive information about the extracted fields on the Blue

Prism side, the standard XML export profile (Export to data files) must be configured in the

Document Definition. 

Note: If, besides export to XML, other standard export profiles are configured in ABBYY FlexiCapture to
export data into other file formats, files in these formats will also be sent back to the FlexiCapture 12
VBO.

3. On the ABBYY FlexiCapture side, click Batch Type Properties → Workflow tab (or Project →

Project properties for the "Default" batch type) and select the Unattended schema.

For a sample ABBYY FlexiCapture project configured for this scenario, see the "Sample FlexiCapture

project" section.

For detailed instructions on how to use ABBYY FlexiCapture as an unattended service and as an

attended service within one workflow, see the "Configuring attended and unattended processing in one

workflow" section.

Sample FlexiCapture project

The ABBYY FlexiCapture Integration Solution for Blue Prism is shipped with a preconfigured ABBYY

FlexiCapture project that contains some test images.
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This example demonstrates how documents can be processed in the scenario that does not require

verification (using the Unattended service batch type). 

For the batch type used in this example, the Unattended processing schema is selected on the

Workflow tab of the Batch Type Properties dialog box. At the export stage, only the XML export profile

is applied.

To run the "Unattended processing" example:

1. Open the sample project on the ABBYY FlexiCapture Project Setup Station and then upload it to

the ABBYY FlexiCapture Application Server.

2. In Blue Prism, install BPA Object - FlexiCapture 12 VBO.xml together with the BPA Process -

FlexiCapture 12 Processor.xml usage example.

3. In the FlexiCapture 12 Processor example, specify the following:

· InputFilePath – the path to the file (including the file name) to be sent to ABBYY FlexiCapture

12

· OutputDir – the folder where the processing results are to be saved

· ServerUrl – the address of the ABBYY FlexiCapture 12 server

· Company - the name of the ABBYY FlexiCapture tenant, if you are working with a tenant

· Username and Password – the credentials of the user's  ABBYY FlexiCapture account

Note: Make sure that the user has the role of Scanning Operator for this project and batch type, or the
role of Administrator.

· ProjectName – the name of the project on the server (specify "InvoiceDemoProject")

· BatchType – the name of the batch type (specify "Unattended service")

4. In Blue Prism, start the FlexiCapture 12 Processor process.

The image file will be sent to ABBYY FlexiCapture 12, where it will be processed, and the processing

results will be immediately sent back to Blue Prism. The processing results in this example will include

the original image file, an XML document, and fields and their data, which Blue Prism will write into a text

document it creates.

ABBYY FlexiCapture as input

To configure this scenario, complete the following steps:

1. On the Blue Prism side, install and configure the FlexiCapture 12 Listener process.

2. On the ABBYY FlexiCapture side, create a script export profile in the Document Definition.

ABBYY FlexiCapture as an attended service

To configure this scenario, complete the following steps:

1. On the Blue Prism side:
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a. Install and configure the FlexiCapture 12 VBO.

b. Install and configure the FlexiCapture 12 Listener process.

2. On the ABBYY FlexiCapture side:

a. Create a scrip export profile in the Document Definition.

b. Click Batch Type Properties → Workflow tab (or Project → Project properties for the

"Default" batch type) and select either the Advanced or Simple schema.

c. On the same tab, select the verification stage and click the Edit.... button to open the

Workflow Stage Properties dialog box and on the General tab, select the Enable web

stations option. Click OK to save the changes.

For detailed instructions on how to use ABBYY FlexiCapture as an attended service and as an

unattended service within one workflow, see the "Configuring attended and unattended processing in

one workflow" section.

Configuring attended and unattended processing in one workflow

When ABBYY FlexiCapture receives a document from Blue Prism, the document may go to the

verification stage or skip that stage and go directly to the export stage, depending on whether the

extracted data require verification or not.

If the extracted data do not require verification, the document goes to the export stage in ABBYY

FlexiCapture and the export results are then sent to Blue Prism. In this case, the sending and receiving

is done by means of the ABBYY FlexiCapture Web API.

If the extracted data require verification, Blue Prism will receive the processing results asynchronously.

First, the ABBYY FlexiCapture 12 VBO will send the data to ABBYY FlexiCapture via the Web API and

get a link to a document verification task on the Web Verification Station. Once the data are verified, they

are sent to the ABBYY FlexiCapture 12 Listener service on the Blue Prism side.

Depending on whether you need to skip verification and send files and extracted data to the ABBYY

FlexiCapture 12 VBO or to perform verification and send files and data to the Blue Prism Listener web

service, you need to configure the workflow in ABBYY FlexiCapture accordingly.

To send results, such as fields and extracted field data, from ABBYY FlexiCapture to the ABBYY

FlexiCapture VBO, you need to configure the standard XML export profile. Additionally, you need to

configure the script export profile so that it is applied only to documents that have gone through the

verification stage.

Configuring the ABBYY FlexiCapture workflow

The ABBYY FlexiCapture workflow can be configured either for each batch type separately or for the

"Default" batch type. To configure the workflow:

1. On the Project Setup Station, either click Project → Project Properties… (if you want to

configure the "Default" batch type) or click Project → Batch types → Edit... (if you want to

configure a particular batch type).

2. On the Workflow tab of the <Project Name> Properties dialog box, change the workflow

schema from Simple to Advanced.
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3. On the same tab, select the verification stage and click the Edit.... button to open the Workflow

Stage Properties dialog box and on the General tab, select the Enable web stations option.

Click OK to save the changes.

4. Return to the Workflow tab in the <Project Name> Properties dialog box and click the Stage...

button to add a new stage. In the Create Processing Stage dialog box, select Automatic and

click OK.

5. In the Workflow Stage Properties dialog box, provide a name for the new stage, make sure that

the Wait for all documents of a batch option is selected, and select the Linked to previous

option.

6. On the Script tab, select Document processing from the Type drop-down list.

7. On the same tab, click the Edit script… button and type in the following script code:

Document.Properties.Set("WasVerified", bool.TrueString);

This script adds a registration parameter to each processed document that indicates whether or

not the given document has gone through the verification stage.

8. On the Entry Conditions tab, select Under these conditions and click the Rule... button to

specify a condition when documents should be sent to the newly created stage.

9. In the Rule Settings dialog box, provide a name for the new rule in the Name field. Then from the

Condition type drop-down list, select Script, click the Script… button and type in the following

script code:
Result.CheckSucceeded = (Document.StageInfo.StageName == "Verification Postprocessing" ||

Document.StageInfo.StageName == "Verification");

This script sets the input condition for the new stage: If a document arrives from the verification

stage, it will be admitted into the new stage and will be provided with a "WasVerified" registration

parameter. 

10.Save the newly configured rule and the new script stage. 

Important! The new script stage must immediately follow the verification stage.

For a sample ABBYY FlexiCapture project configured for this scenario, see the "Sample FlexiCapture

project" section.

Modifying script export profile

The profile will be applied to documents that have gone through the verification stage. To configure both

unattended and attended processing for the same Document Definition, you must first create a script

export profile and then modify this profile as described below:

1. In the Export Settings dialog box, click the Edit... button to modify an export script. 

2. Click the Edit Script... button and add the following code into the script editor:
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using Abbyy.Connectors.Dms.ComFacade;

using Abbyy.Infrastructure.Logging;

using System.Collections.Generic;

if (Document.Properties.Has("WasVerified")

    && Document.Properties.Get("WasVerified") == bool.TrueString)

{

    // TODO: Place the main code of your export script inside these braces.

    // 

    // Factory factory = new Factory();

    // . . .

}

This script will check documents for the "WasVerified" registration parameter, which indicates whether

or not the document has gone through the verification stage, and consequently, whether or not the user

expects to receive verified data.

Once you have modified the script, you need to save and publish the modified Document Definition. To

do this, close the Document Definition editor and click the Publish button.

Note: If documents are being processed within the project at the time when you add a new export
profile or edit an existing export profile, update them to the latest version by pressing Alt+Shift+U or by
selecting Update to Latest Version from their shortcut menu.

Sample FlexiCapture project

The ABBYY FlexiCapture Integration Solution for Blue Prism is shipped with a preconfigured ABBYY

FlexiCapture project that contains some test images.

This example demonstrates how documents can be processed in the scenario that requires verification

(using the Attended service batch type). 

To run the "Attended processing" example:

1. Open the sample project on the ABBYY FlexiCapture Project Setup Station and then upload it to

the ABBYY FlexiCapture Application Server.

2. In Blue Prism, install BPA Object - FlexiCapture 12 VBO.xml together with the BPA Process -

FlexiCapture 12 Processor.xml usage example. 

3. Install BPA Process - FlexiCapture 12 Listener.xml.

4. Open the properties dialog box for the Document Definition named European Invoice, click the

Export Destinations tab, select the Export_to_BluePrism export profile, and click the Edit...

button. Then click Edit script and in the code of the script, specify the actual values required to

connect to the FlexiCapture12Listener web service in Blue Prism:
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· connectorSettings.DmsConnectionSettings.Server = "web-service-address";

· connectorSettings.DmsConnectionSettings.Credentials.Username = "username";

· connectorSettings.DmsConnectionSettings.Credentials.Password = "password";

5. In the FlexiCapture 12 Processor example, specify the following:

· InputFilePath – the path to the file (including the file name) to be sent to ABBYY FlexiCapture

12

· OutputDir – the folder where the processing results are to be saved

· ServerUrl – the address of the ABBYY FlexiCapture 12 server

· Company – the name of the tenant, if the project has been uploaded to a tenant on the

FlexiCapture Application Server (if you are working with ABBYY FlexiCapture Cloud, specify the

name of your company here)

· Username and Password – the credentials of the user's  ABBYY FlexiCapture account

Note: Make sure that the user has the roles of  Scanning Operator and Verification Operator for this
project and batch type, or the role of Administrator.

· ProjectName – the name of the project on the server (specify "InvoiceDemoProject")

· BatchType – the name of the batch type (specify "Attended service")

6. In Blue Prism, start the FlexiCapture 12 Processor process.

The image file will be sent to ABBYY FlexiCapture 12 and, if the document does not require verification,

the standard XML export profile will be applied at the export stage and the export results will be

immediately sent back to Blue Prism. If, on the other hand, the document is sent to the verification

stage, a link to a document verification task on the Web Verification Station will be sent to the ABBYY

FlexiCapture 12 VBO. Once the document is verified, the script export profile will be applied at the export

stage, which will send the data to the ABBYY FlexiCapture 12 Listener. The processing results in this

example will include the original image file and a text file containing the fields and extracted field data.

Installing, configuring, and starting the components

ABBYY FlexiCapture 12 VBO

ABBYY FlexiCapture 12 Listener process

ABBYY FlexiCapture 12 Connector for Blue Prism

ABBYY FlexiCapture 12 VBO

The ABBYY FlexiCapture 12 VBO component appears as a business object to Blue Prism. This object

sends files to ABBYY FlexiCapture 12 and gets back the processing results. 

Important! Before sending image files from Blue Prism to ABBYY FlexiCapture using the ABBYY
FlexiCapture 12 VBO, you must separate the documents into files (one file per document).

The ABBYY FlexiCapture 12 VBO ships with a sample process named BPA Process - FlexiCapture

12 Processor.xml that accesses the VBO.
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The ABBYY FlexiCapture 12 VBO comprises the following components:

Component Description

BPA Object - FlexiCapture 12 VBO.xml A business object that submits files to ABBYY

FlexiCapture 12 and gets back the processing

results.

BPA Process - FlexiCapture 12 Processor.xml An example of using the ABBYY FlexiCapture 12

VBO.

Installing the ABBYY FlexiCapture 12 VBO

To make the ABBYY FlexiCapture 12 VBO and its usage example available on the Blue Prism side, you

need to import the BPA Object - FlexiCapture 12 VBO.xml and BPA Process - FlexiCapture 12

Processor.xml files into Blue Prism. To do this:

1. Open Blue Prism and on the File menu, click Import.

2. Prompted by the on-screen instructions, select the following files to import, one by one:

· BPA Object - FlexiCapture 12 VBO.xml

· BPA Process - FlexiCapture 12 Processor.xml

· Additional objects required to run the FlexiCapture 12 VBO usage example (their default

location is C:\Program Files\Blue Prism Limited\Blue Prism Automate\VBO):

o BPA Object - Utility - File Management.xml

A business object for working with files stored on the local hard drive.

o BPA Object - Utility - Environment.xml

A business object for interacting with the environment (e.g. for running third-party

processes, such as a web browser).

3. Once the import is complete, all the business objects and the usage example will be displayed in

Blue Prism on the Studio tab.

4. Restart Blue Prism for the changes to take effect.

Configuring the ABBYY FlexiCapture 12 VBO

Before you can start using the ABBYY FlexiCapture 12 VBO, you need to create a new process in Blue

Prism:

1. On the Studio tab, right-click Processes and then click the Create Process command on the

shortcut menu.

2. In the workspace, create an element of type Action. Then double-click to open the added activity.

3. In the window that opens, specify the following:

· Name: <name of activity>.
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· Business Object: FlexiCapture 12 VBO.

· Action: Process.

· On the Inputs tab, specify the following input data elements:

o ServerUrl – the address of the ABBYY FlexiCapture server in the following format:

http://<ApplicationServer>

o Company - the name of the ABBYY FlexiCapture tenant (if you are working with ABBYY

FlexiCapture Cloud, specify the name of your company here)

Note: If you are not working with a tenant, leave this field empty.

o Username – the name of the ABBYY FlexiCapture user

o Password – the password of the ABBYY FlexiCapture user

o ProjectName – the name of the project on the ABBYY FlexiCapture server

o BatchType – the name of the batch type that will be assigned to the batch created in

ABBYY FlexiCapture for processing the file

o FileName – the name of the input file

o FileContent – the file to be sent to ABBYY FlexiCapture (must be stored in a data item of

binary data type)

o BatchRegistrationParameters – a collection of objects with "Name" and "Value" text fields

(these objects will be transformed into batch registration parameters on the ABBYY

FlexiCapture side, which can be used, for example, for naming export files)

Note: You can have these elements created automatically by clicking the icon on the left of the value in
the Store In column.

· On the Outputs tab, specify the output data elements that will store the results of the

FlexiCapture 12 VBO Process method:

o DocumentDefinition – the name of the Document Definition that was applied to the input

image by ABBYY FlexiCapture

o Fields – a collection of objects with "Name" and "Value" text fields for storing the names

and extracted values of fields

o Files – a collection of objects with a "Name" text field and a "Content" binary field for storing

exported image files and their names

o VerificationUrl – a text field that stores the URL of the document verification page

Note: Windows authentication will be used to access the URL, which will be returned to the ABBYY
FlexiCapture 12 VBO.

Note: When a batch is created, the ABBYY FlexiCapture 12 VBO adds a
FileNameWithoutExtension registration parameter to the batch. This registration parameter will store
the name of the input file without the file extension. If the BatchRegistrationParameters input list of
registration parameters already includes a FileNameWithoutExtension parameter, the value from
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BatchRegistrationParameters will be passed as the name of the input file to the batch parameters.

Once the activity is configured, the elements of the specified types will appear in the workspace. Data

received from ABBYY FlexiCapture 12 will be recorded in these elements.

Starting the ABBYY FlexiCapture 12 VBO

To start the configured ABBYY FlexiCapture 12 VBO, click the Go button on the Blue Prism toolbar. 

If all the settings are correct, Blue Prism will receive processing results from ABBYY FlexiCapture 12

(the format of the results will depend on the usage scenario). These results will be stored in the output

data elements you created when configuring the VBO. 

If any of the configuration settings is invalid (e.g. if an incorrect ABBYY FlexiCapture 12 address is

specified), an error message will be displayed.

ABBYY FlexiCapture 12 Listener process

The ABBYY FlexiCapture 12 Listener process is deployed on the Blue Prism side. The listener receives

SOAP requests sent by the connector to Blue Prism. It is assumed that the user will import the ABBYY

FlexiCapture 12 Listener into Blue Prism and modify it to suit his needs.

Important! To execute the FlexiCapture 12 Listener process, the machine with Blue Prism that will
receive exported files and data must be running as a Resource PC. To make sure that your Blue Prism
machine is running as a Resource PC, start Blue Prism, click the Control tab, and make sure that the
machine is displayed as "connected" in the Resources window. If this is not the case, open the
command line prompt and execute the following command:
"C:\Program Files\Blue Prism Limited\Blue Prism Automate\Automate.exe" /resourcepc /public

A window named "Blue Prism - Resource PC (Port 8181)" will open where you will see logs for your
Resource PC. Click Hide to minimize this window.

The ABBYY FlexiCapture 12 Listener process comprises the following one file:

Component Description

BPA Process - FlexiCapture 12 Listener.xml A process that accepts and processes SOAP

requests sent by the connector to Blue Prism.

Installing the ABBYY FlexiCapture 12 Listener

To make the FlexiCapture 12 Listener process available on the Blue Prism, you need to import the BPA

Process - FlexiCapture 12 Listener.xml file into Blue Prism and expose the resulting process as a

web service. To do this:

1. Open Blue Prism and on the File menu, click Import.

2. Prompted by the on-screen instructions, select the following files to import, one by one:

· BPA Process - FlexiCapture 12 Listener.xml

· Additional object required to run the ABBYY FlexiCapture 12 Listener usage example (its

default location is C:\Program Files\Blue Prism Limited\Blue Prism Automate\VBO):

o BPA Object - Utility - File Management.xml

A business object for working with files stored on the local hard drive.
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Note: The FlexiCapture 12 Listener usage example already includes a request processing example.
The user can freely modify this example with the exception of the parameters that have to be accepted
on the Start block (see below).

3. Once the import is complete, all the business objects and the usage example will be displayed in

Blue Prism on the Studio tab.

4. On the System tab, expand the Processes node and click Exposure. Then in the top right corner

of the Process - Exposure window, click the Expose a Process link.

5. In the Expose Process dialog box, select FlexiCapture 12 Listener and click Next.

6. In the next dialog box, make sure that FlexiCapture12Listener is specified as the exposed name

of the process and click Finish.

The process will appear in the list of exposed processes. To make sure that the process has been

exposed as a web service, open the following link on the computer running Blue Prism:

http://localhost:8181/ws/FlexiCapture12Listener?wsdl. If all the settings are correct, you will see a

WSDL file with a description of the web service.

Configuring the ABBYY FlexiCapture 12 Listener process

Before you can start using the FlexiCapture 12 Listener process, you need to configure the following

settings in Blue Prism:

1. On the Studio tab, double-click the name of the process to open the process editor.

2. By default, the FlexiCapture 12 Listener process saves received files and fields to the output

folder, where it creates a subfolder with results for each exported document. You can specify an

output folder in the data item named "RootDir."

The user can freely modify this process with the exception of the process name and the set of

input parameters.

The input parameters, their names, and data types must match those in requests sent by the ABBYY

FlexiCapture 12 Connector for Blue Prism. Open the properties of the very first element of the "Start"

process and specify data items and their values in the "Store In" column:

· DocumentDefinition – the name of the Document Definition that was applied to the input image

by ABBYY FlexiCapture (must be stored as the "Text" data type)

· Fields – a collection of objects with "Name" and "Value" text fields for storing the names and

extracted values of fields

· Files – a collection of objects with a "Name" text field and a "Content" binary field for storing

exported image files and their names

· BatchRegistrationParameters – a collection of objects with "Name" and "Value" text fields

(contains the names and values of the batch registration parameters)

Starting the ABBYY FlexiCapture 12 Listener process

The ABBYY FlexiCapture 12 Listener process exposed as a web service is started by a SOAP request

sent during document export from the ABBYY FlexiCapture server to the address of the web service.

http://localhost:8181/ws/FlexiCapture12Listener?wsdl
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ABBYY FlexiCapture 12 Connector for Blue Prism

The ABBYY FlexiCapture 12 Connector for Blue Prism is a set of libraries running on the ABBYY

FlexiCapture 12 side. The purpose of these libraries is to export processing results from ABBYY

FlexiCapture to Blue Prism.

The ABBYY FlexiCapture 12 Connector for Blue Prism:

Component Description

DmsConnector.dll An assembly of models and abstractions common

to different types of connectors.

AfcDmsConnector.dll This library receives as input objects specific to

ABBYY FlexiCapture, converts them into an

internal representation, and sends the converted

result to Blue Prism.

BluePrismConnector.dll This library contains the connector for Blue Prism.

This library sends processing results from ABBYY

FlexiCapture to the ABBYY FlexiCapture 12

Listener web service. 

Connecting the libraries to a Document Definition

Before you can configure document export, you must connect the libraries to your ABBYY FlexiCapture

project. To connect the libraries, complete the following steps:

1. Open the ABBYY FlexiCapture Project Setup Station  and open the project.

Note: To open a project from ABBYY FlexiCapture Cloud, select the Open Project from Server…
command. In the Application Server URL field, specify the address in the following format:
https://europe.flexicapture.com#CompanyName, where CompanyName is the name of your company.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Document Definition Properties... to open the properties of the

Document Definition and then click the .Net References tab.

4. Click the Add... button on the .Net References tab. In the Add Assembly dialog box, select

Attached file from the Type drop-down list and in the Reference field, specify the path to the

DLL file you wish to add. Repeat this step for the AfcDmsConnector.dll, DmsConnector.dll ,

and BluePrismConnector.dll.

ABBYY FlexiCapture export profiles

ABBYY FlexiCapture exports data based on the export profiles in the Document Definitions. To configure

a usage scenario, you need to set up the corresponding export profile. There are two types of export

profile:

1. Standard XML export profile
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2. Script export profile. For details, please see:

· Creating an export profile

· Using a script to specify export settings

· Using an XML file to specify export settings

· Configuration file fields

Standard XML export profile

This profile is used by the ABBYY FlexiCapture 12 VBO to receive image files and extracted field data.

The profile is applied to documents that have not gone through the verification stage.

To configure the standard XML export profile:

1. Open the ABBYY FlexiCapture Project Setup Station and open the project.

2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project. Select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings... and click the Export Destinations tab.

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Export to data files from the Type drop-

down list, select the Save document images option, and click Next.

6. In the Export Data to Files step, make sure the Export path field is empty and click Next.

7. In the Data File Format step, select XML Document (*.xml) in the File type field and click Next.

8. In the Export Images to Files step, select the Save images with data and click Next.

9. In the Image File Format step, select the desired image file format options and click Next.

10.Provide a name for your newly created export profile and click Finish.

11.In the Export Settings dialog box, check the Enabled box for the newly created export profile.

12.Open the <Project Name> Properties (Project → Project Properties...) dialog box and make

sure that the Export root path on the General tab is left empty. This means that the export

profile will send data to Blue Prism.

Creating a script export profile

 To be able to export data from  ABBYY FlexiCapture to Blue Prism via a web service, you need to

configure a script export profile in the Document Definition.

To create an export profile for Blue Prism:

1. On the Project Setup Station open your ABBYY FlexiCapture project.

Note: Make sure that all the necessary libraries are connected to the Document Definition.
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2. Click Project → Document Definitions... to open the list of Document Definitions available for

the project, select the Document Definition for which you want to specify new export settings, and

click Edit....

3. Click Document Definition → Export Settings....

4. Click the Add... button to start the export profile creation wizard.

5. In the Select the Type of Destination step, select Custom export (script) from the Type drop-

down list. Leave the other settings unchanged or modify them as described in ABBYY

FlexiCapture Help.

6. In the Script Export step, click the Edit Script... button, select C# .Net script language and

paste into the script editor one of the two sample scripts available in the connector files:

BluePrism - ExportScript - Configure by script.cs or BluePrism - ExportScript - Configure

by XML.cs. For detailed instructions on using each of these scripts, see Using a script to specify

export settings and Using an XML file to specify export settings below. You can always edit this

script later, but for the moment, save the changes and close the script editor. Detailed

instructions for setting up your export script will be provided below.

7. In the Select the Destination Name step, specify a name for your export profile and click Finish.

8. The newly created export profile will appear in the list of available export profiles in the export

settings dialog box. To make ABBYY FlexiCapture use this profile on Export stage, select the box

next to the profile in the Enabled column.

9. Click OK and close the Document Definition editor. Next, click the Publish button to publish your

Document Definition.

Note: If documents are being processed within the project at the time when you add your new export
profile, update them to the latest version by pressing Alt+Shift+U or by selecting Update to Latest
Version from their shortcut menu.

Once the processing is completed, the document and its metadata are sent from the export stage to

Blue Prism via the ABBYY FlexiCapture 12 Listener web service. The export process is logged in the

Task Log on the Processing Server. 

Note: The event logs are also available on the Processing Monitor tab of the Administration and
Monitoring Console.

When the export completes successfully, the ABBYY FlexiCapture 12 Listener web service will save the

export results on the Blue Prism server in the file format specified by the user.

Using a script to specify export settings

One advantage of using a script is that all the export settings will be automatically used by all the ABBYY

FlexiCapture stations from which data are exported to Blue Prism. When using an XML file, you can only

specify static settings, whereas scripts allow you to specify different file naming rules, file locations, and

field mappings depending on the data contained in the exported document.

When working with ABBYY FlexiCapture Cloud, you also need to use a script to specify export settings,

since ABBYY FlexiCapture Cloud does not provide the ability to store an XML file with configuration on

processing stations.
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However, to modify the export settings, you will have to make changes to the script and, consequently,

publish a new version of the Document Definition.

Please use the script named BluePrism - ExportScript - Configure by script.cs from the connector

files.

Using an XML file to specify export settings

One advantage of using an XML file is that you don’t have to edit the script code or the Document

Definition. All modifications can be made by editing the XML file, which is much simpler than editing the

script code. However, the XML file should be located on every ABBYY FlexiCapture processing station.

And you will also have to synchronize it manually on all of the ABBYY FlexiCapture stations from which

data is to be exported to Blue Prism.

To specify export settings in an XML file:

1. As your export script, use the BluePrism - ExportScript - Configure by XML.cs file from the

ABBYY FlexiCapture Integration Solution for Blue Prism files.

2. Create an XML file named <Project name>_<Document Definition name>.xml. This naming

scheme will allow you to have multiple XML files for different Document Definitions.

3. In the registry of the computer with a processing station, locate

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\BluePrism and in

its "XmlFolder" string value field, specify the path to the folder where the settings file is to be

stored.

4. In the registry of the computer with a processing station, locate the

HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Connectors\ and set its

"BluePrism" string value field to true.

Note: If you do not have the necessary keys in the HKEY_LOCAL_MACHINE \ SOFTWARE registry
branch, create them.

Note: In the code of BluePrism - ExportScript - Configure by XML.cs, you can also find some other
possible naming schemes for your XML files.

Configuration file fields

This section describes the fields of the BluePrism - ExportScript - Configure by script.cs and

BluePrism - ExportScript - Configure by XML.cs configuration files.

Server contains the address of the server where the ABBYY FlexiCapture 12 Listener web service is

located: <Server>http://BluePrism:8181/ws/FlexiCapture12Listener</Server>.

Username contains the name of the user in Blue Prism. For example, <Username>username</Username>.

Password contains the Blue Prism user's password. For example, <Password>password</Password>.

FileName contains the file name template for the document sent to the web service. For example,

<FileName>&lt;Batch&gt;</FileName>.

Note: The name of the document may have an unchanging static part and a changing dynamic part.
The dynamic part is defined by tags, which are replaced by the ABBYY FlexiCapture document property
values at the time of export. Each tag must be enclosed in angle brackets. In the XML file:
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· ‘&lt;’ stands for ‘<’

· ‘&gt;’ stands for ‘>’

Possible tags for the dynamic part of the name:

Note: These dynamically changing tags are case-sensitive and the register of the characters used in
the tags above should be preserved.

· Project for the name of the project in ABBYY FlexiCapture

· Batch for the name of the batch

· DocumentDefinition for the name of the Document Definition in ABBYY FlexiCapture

· SourceFile for the name of the source file

· Identifier for the document identifier in the batch

· BatchType for the name of the batch type

· Time for the current time in yyyy-MM-dd_HH-mm-ss format

If you use the FlexiCapture 12 VBO to send image files to ABBYY FlexiCapture, the batch created for

processing an image will be assigned a FileNameWithoutExtension registration parameter. This

parameter will receive the value from the FileName input parameter (from the VBO). You can also use

the value of this registration parameter in your script for naming export files as follows:

<FileNameWithoutExtension>. Other custom registration parameters can be used to name files in the

following format: <RegParam:ParamName>. You can also use the values of index fields as follows:

<Index:IndexField>.

The following is an example of a document name with a static part:

<FileName>My_static_prefix_&lt;DocumentDefinition&gt;_&lt;Identifier&gt;_and_postfix_</FileName

>

The following is an example of a document name without a static part:

<FileName>&lt;Project&gt;_&lt;Identifier&gt;</FileName>

FieldPairs contains a collection of field pairs.

If your export settings are stored in an XML file, map the fields as follows:

<FieldPairs>

 <FieldPair>

   <AfcField>Invoice Layout\InvoiceNumber</AfcField>

   <DmsField>InvoiceNumber</DmsField>

 </FieldPair>

</FieldPairs>

where:
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· AfcField is a full path to the FlexiCapture Document Definition field from which data are to be read

at the time of export.

· DmsField is field Name in the Fields collection in the Blue Prism FlexiCapture 12 Listener process.

If your export settings are specified directly in the script (BluePrism - ExportScript - Configure by

script.cs), map the fields as follows:

    { @"Invoice Layout\InvoiceNumber", "InvoiceNumber" },

where the first value is the full path to the field in ABBYY FlexiCapture Document Definition and the

second value is the name of the field in the Fields collection in the Blue Prism FlexiCapture 12 Listener

process.

ExportImageSavingOptions contains the image saving options to be used at the time of export, such

as the format of the exported image, its quality, and redacted areas. For the detailed description of the

saving options, please refer to ABBYY FlexiCapture Developer's Help.

http://help.abbyy.com/en-us/flexicapture/12/developer/iexportimagesavingoptions
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